
Ketika mengakses website yang dikelola melalui Plesk, muncul pesan error seperti diatas
Masalah ini biasanya terjadi secara acak atau saat membuka halaman tertentu di situs atau saat login ke website Anda.
Penyebab
Error ini terjadi karena server nginx menerima respons dari backend (seperti PHP-FPM) dengan header yang terlalu besar dan tidak mampu menampungnya dalam buffer default. Beberapa penyebab umum:
Terlalu banyak cookies dari browser
Header terlalu panjang (misalnya karena banyak plugin, redirect, atau rewrite)
Setting buffer nginx terlalu kecil
Handler PHP tidak disesuaikan dengan konfigurasi nginx
Solusi
1. Login ke Plesk Panel
Masuk ke panel Plesk Anda sebagai admin.
2. Cek PHP Handler yang Digunakan
Arahkan ke Domains > [namadomainanda.com] > PHP Settings
Periksa kolom Run PHP as, catat handler yang digunakan, misalnya:
FPM served by nginx
FastCGI
CGI, dll.
3. Tambahkan nginx Directives
Masuk ke:
Domains > [namadomainanda.com]> Apache & nginx Settings
Scroll ke bawah hingga bagian Additional nginx directives, lalu:
I. Jika PHP handler: FPM served by nginx dan Proxy Mode dinonaktifkan
Tambahkan:
fastcgi_buffers 8 16k;
fastcgi_buffer_size 32k;
Ii. Untuk handler lainnya (FastCGI, CGI, dll):
Tambahkan:
proxy_buffers 8 16k;
proxy_buffer_size 32k;
4. Simpan dan Restart
Klik Apply/OK untuk menyimpan perubahan, lalu restart nginx service jika diperlukan atau tunggu sistem menerapkan perubahan otomatis.
Catatan Tambahan
Setelah perubahan dilakukan, bersihkan cache browser dan reload website.
Jika Anda menggunakan Cloudflare atau CDN lainnya, pastikan tidak ada konflik pada sisi header/cookie.
Masalah ini biasanya bersifat teknis dan tidak berhubungan dengan konten website secara langsung.
Penutup
Error 502 Bad Gateway: upstream sent too big header di Plesk umumnya disebabkan oleh konfigurasi buffer nginx yang tidak cukup besar. Dengan menyesuaikan direktif nginx sesuai PHP handler, error ini dapat diatasi dengan cepat.